Auto correct not working after upgrade to MindManager 22

Wilhelm shared this question 11 days ago
Discussion Open

Auto correct has been my favourite part of the tool. After the upgrade, it does not auto correct any entries, it didn't bring over my dictionary, and I'm hoping this is very temporary.

Have anybody else experienced something similar?

Replies (1)

photo
1

Hi Wilhelm,


In MM 22 release we have switched over to Microsoft's SpellChecking engine for better spelling accuracy.


Would you be able to confirm the following, please?

  1. Your system OS language
  2. Your MM language setting (File -> Help -> Options -> Spelling)
  3. Language packs installed on your system (File -> Help -> Options -> Spelling, click Windows Language Settings or can get there via Windows Settings -> Time & Language). For Spelling and AutoCorrect requires appropriate language pack to be installed on the system
  4. Please confirm whether or not "Replace text as type" checkbox is checked in AutoCorrect dialog (Review tab -> Auto Correct ribbon button)

In regards to your custom dictionaries you should be able to add these via MindManager Options -> Spelling -> Custom Dictionaries -> Add.


If you can provide your Custom dictionary and AutoCorrect list files we can take a closer look and provide further help.


Kind Regards,

Paul

photo
1

Thanks, Paul.

I'm happy to re-populate my Custom dictionary and AutoCorrect as I go once auto correct starts to roll a bit more fluently. I can add that I have noticed times when it would correct something, but other times it's just stubbornly ignoring it - adding a red curly line underneath the word, and I have to right-click, auto-correct, and pick the word.


Here are my settings:

  1. Your system OS language | Windows display language is English (Australia)
  2. Your MM language setting (File -> Help -> Options -> Spelling) | Default language for new maps: English (Australian)
  3. Language packs installed on your system (File -> Help -> Options -> Spelling, click Windows Language Settings or can get there via Windows Settings -> Time & Language). For Spelling and AutoCorrect requires appropriate language pack to be installed on the system | English (Australia), Afrikaans, Spanish (Spain)
  4. Please confirm whether or not "Replace text as type" checkbox is checked in AutoCorrect dialog (Review tab -> Auto Correct ribbon button) | Confirmed it is checked.

photo
1

Hi Wilhelm,


Thanks for the quick reply and additional info provided.

It looks like everything is in order.


---

I can add that I have noticed times when it would correct something, but other times it's just stubbornly ignoring it - adding a red curly line underneath the word, and I have to right-click, auto-correct, and pick the word.

---


It seems the words from your use case have multiple auto-correct options available (picking one of the options is required). AutoCorrect should automatically correct misspelled words if there is only one choice.

e.g.

- When you type "Ameria" as topic text it should get automatically corrected to "America"

- When you type "doesn" as topic text it should show with red curly lines underneath and you need to pick one of the words listed under autocorrect menu. Once that is done, anytime you type "doesn" it should get corrected to the word you have selected.


I hope that makes sense. If you are having issue and need more help we can setup a remote call.

Thanks

photo
1

Found one issue when space is entered after a misspelled word (it gets marked as incorrect but not autocorrected). We are working on a fix. Thanks

photo
Leave a Comment
 
Attach a file