How can I get the DATABASE Linker addin working again?

Ary V. shared this question 5 days ago
Answered

The database linker allows you to connect to SQL databases and/or excel files

There is a sample database available. That helps to explain the huge benefits of the addin.

Since I installed MM21 for windows, There are several addins listed that cannot be activated.


If you tick them in the options => addin screen the result is (see image)

The same for Brainstorm, save as Webpages and Analytics view addins

The same reaction when I switch to English.

94fabb72dc5e9e563822727584d0a4f1


What can I do to be able to use those addins again

Comments (2)

photo
1

Hello Ary

The Database Linker connects and works on my system, which is 64-bit MindManager 21.1.231.

The lack of version info on the listing in the Options dialogue indicates a problem with the configuration of the add-in in the registry. It might be worth trying to repair MindManager. If you are using 32-bit MindManager, it might also be worth trying to install the 64-bit version in case the wrong CPU version of the Add-in is present. This issue may affect multiple add-ins as you say.

photo
1

Thanks Nick

I checked and all (OS, APPs, WIndows, Office etc) is on 64 bits

I did a repair of MM21

Did a restart, but the issue still exists.

Maybe it is because I do have older versions installed, but I need those for training classes all the time.

Maybe Marian or Shilpa knows a solution?

photo
1

Hi Ary,


How did you install MindManager 21? Did you use the regular Stub installer link or did you use the Admin builds?

Best,

-Marian

photo
1

Hi again Ary,


The Database linker, Brainstorm, Analytics and Save as Web Pages features were not localized to Dutch. Please be sure you are running MindManager in English, French or German before attempting to re-enable the add-ins.


Best,

-Marian

photo
1

Hello Marian,

I did a standard download from the download area - and had some help from Sonia with the registration of my key.

I have tested with the English selecction

This did not help.

Check if it still works in Vs 2020 And yes inthere it works.

Switched the addins off in vs 2020 stopped the app and tried in vs 21 again. Same result.

I know now that I can demo the options with the older version, but ofcourse I love to have them in vs 21


100bb5c959e5b7a472bffa43f612881d

photo
1

@Marian Here is my system info with the options that work selected:

Product: MindManager (64-bit)

Version: 21.1.231

Mode: Normal

User Name: Ary

Mindjet ID: none

OS: Windows 10 Home 64-bit version 6.3.19041

Tablet: supported; disabled

Multitouch: disabled

Internet Admin Flag: internet enabled

Add-Ins:

Database Linker (disabled)

Microsoft Excel Linker (enabled)

Microsoft Outlook Map Parts (enabled)

Microsoft Project Import and Export (enabled)

Smart Map Parts (enabled)

Sort Topics (enabled)

Save as Web Pages (disabled)

MPX Import (disabled)

Browser (enabled)

Analytic Views AddIn (disabled)

Brainstorming AddIn (disabled)

Excel AddIn (enabled)

FreeMind importeren (enabled)

Gantt Pro (enabled)

HTML5-maps exporteren (enabled)

OMPL importeren en exporteren (enabled)

Microsoft SharePoint Linker (enabled)

Word AddIn (enabled)

XMind-import (enabled)

Verkenner (enabled)

Internet Explorer Version: 11.789.19041.0

Default Browser: Firefox 89.0

Microsoft Office Applications:

Word 16 64-bit

Excel 16 64-bit

Outlook 16 64-bit

PowerPoint 16 64-bit

photo
1

Hi Ary,

As a repair of MindManager 21 did not resolve the issue, I suggest you fully uninstall the application, delete the registry entries at HKEY_LOCAL_MACHINE\SOFTWARE\Mindjet\MindManager\21 and HKEY_CURRENT_USER\SOFTWARE\Mindjet\MindManager\21 and then reinstall.


If that does not resolve the issue, please open a case with MindManager Support.


Best,

-Marian

photo
Leave a Comment
 
Attach a file