Bug when using topic property set by Topic Level trigger as a filter

Alex G. shared this question 55 days ago
Discussion Open

While I find the Topic Level SmartRules trigger very useful, there appears to be a bug when using a topic property set by using it as a filter criteria.

I have created a topic property called Topic Level whose value is set by the Topic Level SmartRules trigger, so that main topics have a Topic Level property value of 1, the next layer of subtopics has a value of 2, and so on. I can then use this topic property successfully in other SmartRules and formulas to apply certain attributes by topic level, or to perform some calculations such as totalling costs by topic level.

However, when I try to use this property as a criterion in a Power Filter I run into problems. All topics at the relevant topic level are selected, but none of the other non-matching topics are hidden. I know parent ones wouldn't be but I expected that child topics would disappear.

I could live with this but what is more puzzling is that non-matching topics can't be faded either. However, the reverse does work, so for example if I want to show only level 3 topics I have to select less than 3 and greater than 3 as the criteria and fade these instead. This is OK as a workaround but is hardly intuitive.

Replies (9)

photo
1

Good morning Alex,

I hope I have understood your problem correctly.

I have rebuilt it and I can hide every single layer by filtering.

However, I have noticed the following.

If I select the trigger level = 1 in the SmartRules, then the 2nd level gets the value 180becc9dccd83eaebc746b36ce2f2bb8

a023353b88c6cf9973fe750ccf5a1002

photo
1

Hi René,

Thanks for your response.

I can hide the selected level by filtering - I just don't seem to be able to do the reverse, ie, show the selected level and hide/fade everything else, except by the method I described.

As for the way levels are numbered, this is by design. The central topic and all floating topics are zero, while main topics (and the next topic under a floating topic) are 1, and so on. Incidentally, zero can't be selected directly, so to select the central topic or floating topics the SmartRule Trigger is Topic Level is Less Than 1.

photo
1

I have tried all 3 variants of filtering. Show, Fade and Hide.

Or do you mean something else?

639edacd9b989201c426609d057cae93

42c8a7c8b518fd70d70a4493a874e75a

b9e63b579b267d967f7e125a184eb7fc

photo
1

This is what I get in a three-level map when I apply the six options for selecting Level 2 in a map where SmartRules have been used to assign Topic Level numbers to a Level Topic Property.

The first shows matching topics where non-matching topics are meant to be hidden:

4e4df15c4f245828540e7cd9d2d894ab

The second shows matching topics where non-matching topics are meant to be hidden:

2e15493565eb0b25378e03b9b62c15f6

The third has the matching topics faded:

1921e3e96662cd2ca8729f91dd8805e4

The fourth shows matching topics hidden:

139b737831a4340fb4628c8f274d53ea

The fifth shows non-matching topics hidden:

f80ad3dc971013476d90e7860f0066fa

And finally, the sixth map shows non-matching topics faded:

530fca2a73f47471400972d215a8d80c

In my view the filters are working correctly in maps 3 to 6. In maps 1 and 2 the right topics are selected, but the non-selected topics are neither hidden or faded.

photo
1

What is the difference between 2 and 6? Isn't that the same thing?

Thats my result for the first one.

2b403a0ede23885d07d630bdbed33132

photo
1

In example 2 the topics matching the filter criterion (ie, Level is exactly 2) are highlighted but the non-matching ones aren’t faded even though this is the selected option.

In example 6 the filter criteria are to select everything but Level 2 and to fade these topics, which is exactly what has happened.

In summary, I can fade or hide the selected level but I can't show the selected level and hide or fade everything else.

photo
1

Hello Alex,

I have tried, but can't find anything. I have shown you my variants in the file.
Variant 2 and 6 are just reversed.
In my opinion the 6 should be called "Fade matching topics". Layers 1 and 3 are selected and 2 fade. We will find the error together ;-)

photo
1

I’ve put 2 and 6 side-by-side below. Hopefully this will make it clear that in example 2 the Level 2 topics are selected but the others are not faded, whereas in example 6 the Level 2 topics are not selected but are the only ones that are not faded.

However I’ve also just realised that my headings for examples 6 and 5 are a little misleading. Technically it’s the matching topics which are faded and hidden respectively, as the description of the filtering makes clear. The topics selected in the filtering in each are those less than and greater than level 2, leaving the latter unaffected,

433cd80467659b3fbe338d9dc6f93cbc

photo
1

Bizarrely, this appears to be working OK today. I don't know what happened overnight, but now I can fade or hide non-matched topics based on topic level in maps that weren't able to do this yesterday. It's all very strange.

photo
1

All's well that ends well.

He preferred to give up ;-)

And a Happy New Year Alex.

photo
Leave a Comment
 
Attach a file