How to use automated pasting of links in MindManager maps.

Ary V. shared this question 6 months ago
Answered

In the MindManager 23 announcement we read:

"Pasting links into MindManager is now automated. When a link is copied to the clipboard and then pasted into a topic in MindManager, it will automatically be interpreted as a topic link. This makes it easier to link to external resources or other topics within MindManager maps. If a paragraph of text contains one or more links, MindManager will also automatically recognize them and add it as a topic link or links. This can be a useful way to quickly add multiple links to your map without having to manually add each one.

How is this done?
I can't find anything about it in the help.
Please show me the way ...

I use a Dutch language version, can it be that we don't have it?

Best Answer
photo

Just a thought Ary - in MindManager Options under Edit, do you have the box for “On paste, use formatted text from original” ticked? If it isn’t ticked then not only the formatting but also all links get stripped out when you paste imported text.

Replies (2)

photo
1

Hi Ary,

All you do (at least in the English version) is highlight some paragraphs of text containing one or more website URLs in the source document or web page, copy and paste in MindManager. As expected, the paragraphs will become topics in the map, including the web addresses, but the latter will also become hyperlinks on the same topics. Note that this only seems to work if the text is pasted as formatted.

photo
1

Unfortunatekly Alex.. In my MindManager 2023 it does not work.

The Dutch version appeared some years ago without me asking, don't know who wants it, since everybody speaks some kind of english overhere, but ofcourse I train students using the version in their own language.

The translation is however terrible and done by someone NOT NATIVE, maybe a lot of Google translate nonsense.
I had some conversation with Marian about this. He requested me do do a better Job, but this will take at least 5-8 day's to get it up to my standards, so nothing is done.

I made 2 small video's One using the dutch version and the second in english. Maybe you see something thta I miss.

photo
1

Hi Ary,

That's very strange. At first I thought after seeing your videos that it might be a problem specifically with text copied from emails but that isn't the case, at least in the English-language version I have - 23.0.154 (32-bit). I did a similar test and when text is copied from emails the URLs appear in the map as hyperlinks on topics in the same way they do in text copied from other sources.

I think this is probably a case for product support.

photo
1

hello Alex,

Thanks.


Yes I will need to go to Support for this.

The only extra suggestion I may have is that I have many different MindManager versions installed, because I train people in companies that have not yet upgraded.

Never had a problem with that, but maybe I need to get rid of vs 2020, 21, 22 to be sure nothing interferes.

As soon as it is solved I will mention it here.

photo
1

Hi Ary,

I'm sorry to hear this is not working for you. While I can't reproduce the issue on my end, I have asked our QA Team to investigate. I don't believe having multiple versions of MindManager installed on the system is the cause, looks more like a faulty installation. I would suggest uninstalling MindManager 23 and then reinstalling and if that does not fix the issue, cleaning the registry entries for MM 23 may be the next step.

Best,

Marian

photo
1

Hi guys,

it seems the help wording is incorrect, the way it works is that you would copy some text and paste it directly in MindManager as new topic, (so select a topic and click paste to create a new subtopic), not inside a topic, and that should work. Please let me know if the issue is resolved,

Adding a small video as exemple of both behaviors.


thank you,

Francis

photo
1

Hi Francis,

I’m afraid the issue isn’t resolved - Ary has been copying and pasting text in exactly the way you recommend, as can be seen in the videos he posted.

Also, I can confirm that having several older versions of MM installed does not cause the problem.

photo
1

Well... @Marian


I have followed your suggestion

I would suggest uninstalling MindManager 23 and then reinstalling and if that does not fix the issue, cleaning the registry entries for MM 23 may be the next step.

To be sure I also uninstalled all older versions.

Next I went to https://www.mindmanager.com/mm-win-exe to download and install vs 23 again.

I tried and it still does not work as expected.

All results are similar to what I mentioned before.

To be sure I also tried to copy and past from a website. No luck.

So I will need to clean the registry entries.

HOW DO I DO THAT? In all these years as MIndManager user I have never done that.

Could you provide a step by step instruction or video?

Thanks alot

photo
1

Hi Alex,

do you know what OS Ary is on? Also could one of you send me a video of how the text is being added, I just checked with version 23 in Dutch on my machine, it seems to work. I'm on windows 10, so maybe a Windows 11 issue? We could try a remote session but best is to go through customer service so they can set it up. In the meantime Ary could provide me with the video and try reinstalling MindManager, best prior to reinstalling is to delete the MM23 folder under appdata "C:\Users\UserName\AppData\Local\Mindjet". If he's on windows11 we'll have someone try that as well...

Thank you Alex,

Francis

photo
1

I have created a request with support - customer service but had no answer yet.

I am on Windows 10 and use Office 365 on my desktop

I will delete the complete MM23 folder before I reinstall again.

After the reinstall I created a video see attached

photo
1

Just a thought Ary - in MindManager Options under Edit, do you have the box for “On paste, use formatted text from original” ticked? If it isn’t ticked then not only the formatting but also all links get stripped out when you paste imported text.

photo
1

Hi Alex,

You are a Genius.

I had this one setting always switched on, but maybe the default has changed when installing the new version.

but anyway the paste of text with links now does what is expected

photo
1

Thanks Ary you're very kind, but I'm no genius. In fact I should probably apologise for not recalling this earlier.

A couple of months ago I responded to a question on the forum from someone who found there was a few seconds' delay when pasting formatted text from an external source. I wondered if the new facility for pasting links in V23 had something to do with this and discovered that pasting text unformatted does remove links as well as formatting.

The OP confirmed that doing this does speed things up and also pointed out that you could set this as a default by removing the tick from the relevant box in the Edit settings.

I only recalled this discussion and its potential implications for your situation this morning. In my defence I should point out that this solution seems to have also been missed by MindManager support staff as well.

Two other comments. First, I really do think there should be a tick box in the settings specifically to control whether links are recognised when pasting text and this should be separate from the formatted/unformatted tick box.

Second, there may be something in your comment about the default setting for this having changed on installation. I responded recently to someone whose notes pane had moved to the left side of the screen and discovered that their left-hand interface setting had suddenly been ticked. Andreas commented that he'd seen a few other cases of this, so perhaps this may be an intermittent problem with some settings in V23.

photo
1

Thank you Alex.

photo
1

Second, there may be something in your comment about the default setting for this having changed on installation. I responded recently to someone whose notes pane had moved to the left side of the screen and discovered that their left-hand interface setting had suddenly been ticked. Andreas commented that he'd seen a few other cases of this, so perhaps this may be an intermittent problem with some settings in V23.



photo
1

The left-handed interface setting is automatically enabled when MindManager detects Tablet PC functionality in Windows being turned on, which is usually due to the device having a touch screen like a Microsoft Surface Device but this goes back to the early 2000's when Microsoft first introduced touch or pen support.

The logic for this behavior in MindManager is the Mouse and Pen mode icons appear in the lower left corner so the various Task Panes would be in the same location as well.


I hope that helps.


Best,

Marian

photo
1

I’m not sure if Jerry S is a real person who has repeated the last part of my comment relating to the left-handed interface without attribution or using quotation marks, or on the other hand if this is a further example of the AI-generated spam we’ve seen recently on this forum, but either either way it’s pretty odd.

---